Cisco Etherchannel bonding: How to configure layer 2 etherchannel using LACP and PAgP

Etherchannel is a port aggregation feature that allows for the bonding together of two or more switch ports into a logical interface. The logical port, with the combined capacity of the individual ports, is then used to carry layer two frames or layer three packets, depending on the configuration. Multiple interfaces can be combined using one of these port aggregation protocols: PAgP or LACP. In this post, we will look at each protocol and its configuration method for layer 2 etherchannel.
etherchannel bundling
Etherchannel bundling with three gigabit interfaces

 

Link Aggregation Control Protocol (LACP)

Link Aggregation Control Protocol is an industry standard 802.3ad aggregation protocol that allows for the combination of the bandwidth capacity of multiple switch ports into a single logical interface for load balancing and redundancy. It is available on both Cisco and non-Cisco switches. All participating ports in a single logical interface must have the same settings such as duplex mode, speed and must all the either access or trunk ports. LACP allows for the aggregation of up to 16 switch ports but only a maximum of 8 can be active at a time while the remaining 8 will be in standby mode. LACP can be configured either in active or passive mode. Active mode means the channel interface will actively try to negotiate interchannel bonding while passive will only responds to a request for an etherchannel bonding but will not initiate the process.

LACP Configuration

To successfully configure etherchannel bonding between two Cisco switches using LACP as the aggregation protocol, the following configuration commands are required: In this demonstration, we are going to establish an etherchannel bonding between switches 1 and 2, using three fast ethernet ports on both switches. This will provide a bandwidth capacity of 300Mbps between both switches instead of the 100Mbps provided by a single port.
SW1(config)#interface range f0/1 – 3
SW1(config-if-range)#switchport trunk encap dot1q
SW1(config-if-range)#switchport mode trunk
SW1(config-if-range)#channel-group 20 mode active
SW1(config-if-range)#end
SW2(config)#interface range f0/1 – 3
SW2(config-if-range)#switchport trunk encap dot1q
SW2(config-if-range)#switchport mode trunk
SW2(config-if-range)#channel-group 20 mode active 
SW2(config-if-range)#end
To verify that the ports have been bonded and are working perfectly, use the command sh etherchannel summary from the privilege mode. Each participating port should
have a P in front of it.
Switch#sh ether sum
Flags: D – down P – in
port-channel
I – stand-alone s –
suspended
H – Hot-standby (LACP
only)
R – Layer3 S – Layer2
U – in use f – failed to
allocate aggregator
u – unsuitable for
bundling
w – waiting to be
aggregated
d – default port
Number of channel-groups
in use: 1
Number of aggregators: 1
Group Port-channel
Protocol Ports
——+————-+———–+———————————————-
20 Po20(SU) LACP
Fa0/1(P) Fa0/2(P) Fa0/3(P)
Switch#
The show etherchannel command will show you the mode of etherchannel running on the switch (if it is layer 2 or 3) as well as the number of ports participating in the etherchannel and the aggregation protocol. See output from sh etherchannel command.
Switch#sh ether
Channel-group listing:
———————-
Group: 20
———-
Group state = L2
Ports: 3 Maxports = 16
Port-channels: 1 Max
Port-channels = 16
Protocol: LACP

Port Aggregation Protocol (PAgP)

Port Aggregation Protocol is a Cisco proprietary protocol that does the exact same thing as LACP but with a slight difference. PAgP only runs on Cisco routers and a few of other vendors’ equipment who have the license to run PAgP. Unlike LACP which allows for up 16 ports to be aggregated in which only eight can be active at a time while the remaining eight are placed on standby mode, PAgP allows for a maximum of eight active ports with no standby features.

PAgP configuration.

The configuration of PAgP is the same as LACP only that the available channel modes are desirable and auto. For PAgP etherchannel bonding to be negotiated between two switches, one side has to be desirable while the other is either desirable or auto. The link will not come up if both sides are configured for auto.
SW1(config)#interface range f0/1 – 3
SW1(config-if-range)#switchport trunk encap dot1q
SW1(config-if-range)#switchport mode trunk
SW1(config-if-range)#channel-group 20 mode desirable
SW1(config-if-range)#end
SW2(config)#interface range f0/1 – 3
SW2(config-if-range)#switchport trunk encap dot1q
SW2(config-if-range)#switchport mode trunk
SW2(config-if-range)#channel-group 20 mode auto 
SW2(config-if-range)#end 

 

Spread the love

Timigate

I believe that Africa will advance technologically if knowledge is shared among the living than out of greed, taken to the grave.

Leave a Reply

Your email address will not be published. Required fields are marked *