How to configure PPPOE server/client on a Mikrotik router

Mikrotik PPPOE is a type of point to point protocol that is deployed over ethernet. It is used mostly by ISPs to provide internet access to their customers. This is so because Point to point Protocol over ethernet (pppoe) provides ISPs with the ability to extensively manage connected users. In this demonstration, I will share with us how to configure a pppoe server and client on a Mikrotik router.

mikrotik pppoe

Before proceeding with the pppoe configuration, it is expected that your router must have been configured with all requirements needed for internet access. To see how to configure a Mikrotik router for internet access, click here.

 

Mikrotik PPPOE Server

 

This is configured on an ISP router, mainly on a port connecting to the router at the customer’s location. The pppoe server will authenticate connected clients and provide them with the required IP address to browse the internet. First thing to do when configuring a pppoe server is to set the IP pool. This is the
pool of IPs that will be assigned to connected pppoe clients. Click on IP>>Pool>>add>>enter a name for the pool>>enter the address range for the pool. Alternatively, click on new terminal from the main menu and enter the code below. Make sure to edit the IP address range and pool name to what you would want.

 

/ip pool

add name=”pppoe-pool” ranges=192.168.1.10-192.168.1.20

 

Next, you create the pppoe profile: Copy, edit and paste the code below in the new terminal window.

 

/ppp profile

add name=pppoe-profile local-address=192.168.1.1 remote-address=pppoe-pool

 

Next, is to create a secret key the pppoe server will use for authenticating pppoe clients. This key must be same on the clients for them to successfully authenticate. Click on the new terminal tab from the main menu, edit the code below to suite your requirement and paste it in :

 

/ppp secret

add name=user password=pass1234 service=pppoe profile=pppoe-profile

 

Make sure that the profile name matches the one created earlier. As can be seen, mine was named pppoe-profile. Next, we enable pppoe server. Still in the new terminal window, copy, edit the code below and paste in:

 

/interface pppoe-server server add

service-name=internet interface=ether2 default-profile=pppoe-profile disabled=no

 

 

You may also like: How to capture YouTube and Facebook IPs on Mikrotik using scripts

 

Make sure that the interface name entered is the one connecting to the pppoe client and that there is no IP assigned to this interface. If you assign an IP to this interface, clients can easily connect without the need for pppoe authentication. The only IP associated with this interface should be the local address you assigned when creating the profile above.

 

PPPOE Cleint:

On the client, click on new terminal from the main menu, copy, edit the code below and paste:

 

/interface pppoe-client add

name=pppoe-user-mike user=user password=pass1234 interface=ether1 service-name=internet disabled=no  

 

Make sure the password matches the one set on the server and that the chosen interface is the one connecting the client to the pppoe server.

 

If you find it difficult entering the above codes and would prefer the guide from winbox, click here.

 

If you enjoyed this tutorial, please subscribe to this blog to receive my posts via email. Also subscribe to my YouTube channel, like my Facebook page and follow me on Twitter

 

Spread the love

Timigate

I believe that Africa will advance technologically if knowledge is shared among the living than out of greed, taken to the grave.

Leave a Reply

Your email address will not be published. Required fields are marked *